4
$\begingroup$

It appears that the MO TeX does not understand macros \mod and \pmod any more; it used not to be the case. As a result for many questions the typesetting is broken.

$\endgroup$
  • $\begingroup$ Apparently, Dima is not the only one having a problem with pmod; mathoverflow.net/questions/37097/… $\endgroup$ – Gerry Myerson Jan 3 '16 at 14:59
  • $\begingroup$ On my Mac symbols \mod \pmod \pod are not displayed, as well as \binom and \choose. $\endgroup$ – Włodzimierz Holsztyński Jan 3 '16 at 18:05
  • $\begingroup$ However \bmod does work. $\endgroup$ – Włodzimierz Holsztyński Jan 3 '16 at 18:06
  • 1
    $\begingroup$ MathJax v2.6 was released on Dec 30. If clearing the browser cache helped, this error may have come from having components from different versions of MathJax in the browser cache simultaneously. $\endgroup$ – Peter Krautzberger Jan 10 '16 at 2:11
  • 2
    $\begingroup$ @PeterKrautzberger Could you write an answer? When I had this problem and arrived at this page I did not notice this tip. I think a more prominent place would be better. $\endgroup$ – Dirk Jan 25 '16 at 13:32
  • 1
    $\begingroup$ @Dirk thanks for alerting me. I never got a confirmation and I'm not an active user. Will write one now. $\endgroup$ – Peter Krautzberger Jan 25 '16 at 22:05
7
$\begingroup$

MathJax v2.6 was released on Dec 30, close to the OP. These updates can lead to errors if a browser cache contains a mix of MathJax components with different versions. In that case, clearing the browser cache from all things MathJax (and for some browsers, additionally restarting the browser) should help.

$\endgroup$
4
$\begingroup$

Seems OK to me...

$5 = 7 \pmod2$

$5 \equiv 7 \mod 2$

Perhaps Dima should tell us what OS and browser versions he is using.

$\endgroup$
  • $\begingroup$ Have you checked the main site as well (meta might behave differently)? $\endgroup$ – Stefan Kohl Jan 3 '16 at 13:23
  • $\begingroup$ Now I did, and it looks the same as here. $\endgroup$ – Gerald Edgar Jan 3 '16 at 13:46
  • $\begingroup$ Firefox on Ubuntu Linux 14.04 $\endgroup$ – Dima Pasechnik Jan 3 '16 at 14:57
  • $\begingroup$ works on my Android phone, though $\endgroup$ – Dima Pasechnik Jan 3 '16 at 14:57
  • $\begingroup$ And now it is OK with the setup that did not work when I posted this question. (I can say that I had that \mod etc problem for a couple of days at least). $\endgroup$ – Dima Pasechnik Jan 3 '16 at 15:14
  • 2
    $\begingroup$ Both of these render as "[Math Processing Error]" for me... $\endgroup$ – Andy Putman Jan 3 '16 at 20:05
  • 1
    $\begingroup$ @AndyPutman: Did you try clearing your cache? $\endgroup$ – Emil Jeřábek supports Monica Jan 4 '16 at 14:21
  • 3
    $\begingroup$ When I first visited this page, I saw errors as mentioned by Andy Putman. When I refreshed the page, the MathJax came out fine. $\endgroup$ – Joel Reyes Noche Jan 5 '16 at 4:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .