In my hotel in Shanghai, I get the error message

MathOverflow requires external JavaScript from another domain, which is blocked or failed to load.

Is there a work around for this? Posts load very slowly, I cannot vote, some comments are not viewable,...

  • 1
    $\begingroup$ Perhaps it's a slow internet connection? (I'm not sure, since I'm not a computer expert.) $\endgroup$
    – user62675
    Commented Jun 16, 2014 at 1:00
  • 11
    $\begingroup$ Perhaps you're enjoying Chinese censorship? MathOverflow now works under https, so you might just try changing the URL to https://mathoverflow.net/ and seeing what happens. Alternatively, presumably you have ssh access to some computer back home. Run ssh -D 1080 [email protected], and then tell your browser to use a SOCKS proxy on port 1080. (Google for more details, or just ask me.) This will tunnel you out of the Great Firewall. $\endgroup$ Commented Jun 16, 2014 at 1:57
  • $\begingroup$ Thanks for the fix, Scott. $\endgroup$ Commented Jun 16, 2014 at 8:33
  • $\begingroup$ I have yesterday seen this message as well, from Germany -- but the problem was intermittent -- sometimes I saw that message, sometimes the formulas were rendered strangely or not at all or omitted completely. But now everything seems to work well again. $\endgroup$
    – Stefan Kohl Mod
    Commented Jun 16, 2014 at 8:44
  • $\begingroup$ Your problem was likely different, Stefan. My problem was the Chinese firewall that had to be circumvented. $\endgroup$ Commented Jun 16, 2014 at 12:38
  • 4
    $\begingroup$ Scott's comment should probably be an answer. $\endgroup$ Commented Jun 16, 2014 at 20:25

1 Answer 1


This is due to some very aggressive firewalls permitting our sites, but not our CDN (sstatic.net). You'll hit this, unfortunately quite often, in mainland China. If you're in the Special Administrative Regions (HK/Macau, etc) then you should be fine.

You have two options:

  • Go with https:// (which sometimes works)
  • Go with a proxy service like Hola Internet1 or similar if that fails

It's hard to design around a use case of someone intentionally breaking the Internet, so unfortunately, there's not much we can do to get around it (if we want to use a CDN, which we really need to do). We're hoping that enough bug reports (yes, the GWOC does have a bug tracker so 'legitimate' domains can be unblocked) finally gets them to stop blocking our CDN.

1We don't officially endorse any third party proxy, I've just had luck with them, as have users that acted on my recommendation to try them.

  • $\begingroup$ I tried https; it does not work. I did not try Hola, but Scott Morrison's second suggestion allows me to work around the problem. If Scott writes it as an answer I will accept it. $\endgroup$ Commented Jun 23, 2014 at 15:17
  • 4
    $\begingroup$ Why was this answer downvoted? $\endgroup$
    – Todd Trimble Mod
    Commented Jun 23, 2014 at 17:12
  • $\begingroup$ @ToddTrimble because I lost my keys. Could be because it was answered in comments which I mostly reiterated, but .. it's my job to do that and make sure these have actual answers :) $\endgroup$
    – Tim Post
    Commented Jun 24, 2014 at 5:15
  • $\begingroup$ @BillJohnson I think in some sense Scott Morrison's suggestion is a special case of the second point here, as it suggests to use a particular proxy. $\endgroup$
    – user9072
    Commented Jun 24, 2014 at 15:45
  • $\begingroup$ @quid For me the key point in Scott's comment was to use the ssh -D 1080 command when connecting to my home domain via ssh. I did not get that suggestion from my system administrator. I now set one browser to use that and a different browser to use the local port in Shanghai. $\endgroup$ Commented Jun 26, 2014 at 1:32
  • 1
    $\begingroup$ @BillJohnson Yes, a simple SOCKS proxy is the easiest way to go if you (1) have a decent SSH client that'll do it for you and (2) something you can connect to. I wrote a nice init script that wraps that all up simply with a nice launcher program, gotta dig that up and get it in my public repo. $\endgroup$
    – Tim Post
    Commented Jun 26, 2014 at 5:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .