For the last several days I've had no luck using the citation helper. Whenever I attempt to search for anything, although a search seems to be ongoing even letting it sit for minutes doesn't produce any results.

citation helper search

(The dots below the search string cycle as though searching. Screenshot courtesy of Martin Sleziak; thanks.)

I inquired if anyone else was having difficulty in the MathOverflow chat room, and so far 100% of the respondents have reported a similar issue. (Granted, so far there has only been one response.)

  • According the the Chrome console, I get the following errors, Failed to load resource: net::ERR_INSECURE_RESPONSE and GET https://ec2.mathoverflow.org/cite?q=&_=########### net::ERR_INSECURE_RESPONSE.
  • According to the Microsoft Edge console I'm getting the error SCRIPT7002: XMLHttpRequest: Network Error 0x800c0019, Security certificate required to access this resource is invalid.

This seems to be a security certificate issue.

  • 2
    $\begingroup$ The certificate is expired since february 20. Which shouldn't happen in this case as it's from Let's Encrypt, which is meant to be set up with an automated way of certificate renewal. This automation seems to be broken for some reason. $\endgroup$
    – user35354
    Mar 2, 2017 at 18:30
  • $\begingroup$ And we finished the zbMath helper a while ago anyway. $\endgroup$
    – Asaf Karagila Mod
    Mar 2, 2017 at 20:04
  • 3
    $\begingroup$ Sorry --- I'll fix the certificate automation later today. Not sure what happened. I'll also contact Stack Exchange again about plugging in the new zbMath backend... $\endgroup$ Mar 2, 2017 at 22:20
  • $\begingroup$ @Scott: Any news on the former task? It seems that the citation helper still fails to fetch results. $\endgroup$
    – Asaf Karagila Mod
    Mar 5, 2017 at 18:30
  • 2
    $\begingroup$ Let's Encrypt seems to have become broken on Amazon Linux, which is where we run the citation backend. I'm stuck for now, and am about to start escalating moving to our zbMath backend. $\endgroup$ Mar 5, 2017 at 22:23
  • $\begingroup$ We've finally switched over to the zbMath backend, so this issue is now irrelevant. $\endgroup$ Mar 13, 2017 at 20:58

1 Answer 1


Oded installed a new version of Scott Morrison's citation helper that uses an API to Zentralblatt, which solved the problem. This change was already in the works, but I kept dropping the ball. Oded and Scott deserve the credit.

For the curious, I have a SEDE query that shows the 218 extant posts which have included citations. You might also be interested to know that Computational Science has also started using the feature and has four posts with citations.

  • $\begingroup$ Somewhat off topic here, but is there any chance of math.se getting this, too? $\endgroup$
    – user642796
    Mar 10, 2017 at 4:27
  • $\begingroup$ Let me point out that there have been repeated requests that the feature will be implemented on Mathematics as well. $\endgroup$
    – Asaf Karagila Mod
    Mar 10, 2017 at 17:43
  • $\begingroup$ Is it just me, or is the citation helper still not working? I see exactly the behaviour described in the original post: a never ending cycle of three periods. $\endgroup$ Mar 13, 2017 at 13:08
  • $\begingroup$ Though the root cause may be unrelated: the web console shows repeated (slowly) GET requests to zbmath interwoven with “TypeError: result.links[j].includes is not a function @ cdn.sstatic.net/js/third-party/…”. $\endgroup$ Mar 13, 2017 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .