4
$\begingroup$

This question has a block of valid LaTeX which doesn’t render when viewed except on edit mode. Below are 2 screenshots from my phone. One in edit mode and the other in regular mode.

Edit mode, rendered successfully

Regular mode, digit string rendered as phone number

I used QuickLaTeX to confirm the MathJax was valid.

$\endgroup$
8
  • 4
    $\begingroup$ It works for me. The screenshot suggests that this is caused by some browser addon/malware on your device that highlights phone numbers (the linked “+13591409”, which presumably breaks MathJax). Try to disable it. $\endgroup$ Commented Jun 28 at 6:36
  • 6
    $\begingroup$ You can have a look here to see whether some information there might be helpful: Math numbers rendered as FaceTime phone number and MathJax fails when rendering long digit strings on iOS. (Both of the linked posts are from Mathematics Meta.) $\endgroup$ Commented Jun 28 at 6:52
  • 4
    $\begingroup$ Oh, so the malware is Apple itself, that does it automatically and it can't be turned off? This is so mindboglingly stupid on so many levels. $\endgroup$ Commented Jun 28 at 7:15
  • 3
    $\begingroup$ I inserted thin spaces as thousands separators in the long numbers, which should in theory fix the issue with Apple malware (can you confirm this?). It is in general a bad idea to get around specific browser bugs by making changes to posts that affect everybody else, but in this case, I believe it actually improved readability. $\endgroup$ Commented Jun 28 at 8:06
  • $\begingroup$ @EmilJeřábek it now renders correctly $\endgroup$ Commented Jun 28 at 15:16
  • 1
    $\begingroup$ Although preview bugs are maddening, they're going to happen, often through MathJax's fault rather than Apple's, so it's probably not worth worrying too much about any individual one. For myself, I've taken to just writing the best I can, posting it even if the preview is borked, and then making use of the 5-minute grace period if necessary to fix anything that's actually borked on rendering. $\endgroup$
    – LSpice
    Commented Jul 20 at 1:19
  • 1
    $\begingroup$ @LSpice But this was not a preview bug. The final post was broken, not the preview. $\endgroup$ Commented Jul 20 at 6:10
  • $\begingroup$ @EmilJeřábek, re, thanks; I misread. $\endgroup$
    – LSpice
    Commented Jul 20 at 9:59

0

You must log in to answer this question.

Browse other questions tagged .