4
$\begingroup$

I encountered Topos associated to a category with glowing-red \*s in it. When trying to edit them out I discovered that whenever I try to replace an $f^\*$ with an $f^*$, the whole text becomes garbled, and similarly for _\*. I finally managed to tame it by replacing all *s with \asts. Seems to be specific to that particular page, there are lots of normally looking *s everywhere else.

Is this a known phenomenon?

$\endgroup$
6
  • 4
    $\begingroup$ When there are multiple unescaped * in the post, they may be interpreted by the Markdown parser as markup for italics. $\endgroup$ Apr 15 at 6:58
  • 3
    $\begingroup$ Though in theory, MathJax formatting should take precedence over Markdown, and now that I’ve tried it, the page actually renders in the expected way when I replaced the \asts back with *s. So I can’t reproduce what you are describing. Perhaps some javascript was incorrectly loaded in your browser or something. (The reason the original post had \*s was that it hasn’t been touched since 2012, and back then, Markdown processing was done before MathJax, hence Markdown italic markers had to be escaped, indeed.) $\endgroup$ Apr 15 at 7:36
  • 2
    $\begingroup$ (To clarify my last parenthetical remark: Markdown processing still has to be done before MathJax for the simple reason that Markdown is translated to HTML on the server when the post is edited, whereas MathJax is processed by the client on the fly. But the parser is now aware of MathJax and treats chunks of MathJax code as black boxes where Markdown is not interpreted.) $\endgroup$ Apr 15 at 7:47
  • 2
    $\begingroup$ @EmilJeřábek Sadly now I cannot reproduce it myself! No idea what happened, maybe indeed there was a temporary javascript issue or something. I think I will still leave the question open, in case this happens again to someone somewhere. I will remove the bug tag for the time being, though. $\endgroup$ Apr 15 at 8:05
  • 3
    $\begingroup$ Using this query one could find some other posts with "red asterisks" for testing. For example, questions 450036 and 132534. But I wasn't able to reproduce the problems described in the post. (I wonder whether "text became garbled" describes the situation in the preview or the situation after the edit - in the two posts I've mentioned I only tried the preview.) $\endgroup$ Apr 15 at 17:25
  • 5
    $\begingroup$ I've come to the conclusion that any problem encountered in preview should be treated as transient until it can be explicitly reproduced. Especially when editing posts with a big preamble, I often find that the previewer will get confused and decide that part of the preamble no longer belongs in math mode, resulting in a garbled mess. Since this confusion never seems to extend into the post itself, I think it's worth taking advantage of the 5-minute grace period to submit an edit that seems right even if it doesn't preview, and then to fix it if the actual rendered post is still screwy. $\endgroup$
    – LSpice
    Apr 15 at 22:25

0

You must log in to answer this question.

Browse other questions tagged .