enter image description here

Chrome, for comparison:

enter image description here

Happens on Windows 10, both browsers are up to date. Should I use the tag? Does anybody else encounter this? Can it be something on my side?

After the question in a comment by Martin Sleziak: actually I cannot access the MathJax menu anywhere on Firefox.

Additional info:

When I edit that question and replace the $$ with \begin{multline*} .. \end{multline*} the wrapping renders correctly.

In Firefox under WSL inside the same system it renders correctly, and I can access the MathJax menu too.

  • 2
    $\begingroup$ Does the behavior change if you switch the math renderer? (See also: How do I change Math Renderer for MathJax?) $\endgroup$ Jun 3, 2021 at 4:10
  • $\begingroup$ @MartinSleziak Good question! I cannot access the MathJax menu anywhere on Firefox! $\endgroup$ Jun 3, 2021 at 4:35
  • 2
    $\begingroup$ That's interesting - here's is a screenshot showing also what I get in FF (including the MathJax menu): i.sstatic.net/dL04K.png To save work for the user who want to try this on the same post, I will add a link: Integral representation of product of two Whittaker functions. $\endgroup$ Jun 3, 2021 at 4:45
  • 2
    $\begingroup$ Did you try to force reload the page to override cache (Ctrl+Shift+R or Ctrl+F5)? $\endgroup$ Jun 3, 2021 at 6:33
  • 2
    $\begingroup$ @EmilJeřábek Tried now, rendered MathJax momentarily turns into TeX code and then returns to the same $\endgroup$ Jun 3, 2021 at 6:56
  • 1
    $\begingroup$ Are you really sure you cannot access the MathJax menu? It can be somewhat difficult to get it right at times. You need to place cursor over a rendered element of the MathJax expression (ideally, something with a large area, such as one of the $W$’s in the displayed equation); in most (but not all) modes, a correct place is visually indicated by the pointer cursor changing to a text cursor. Then you right click. $\endgroup$ Jun 3, 2021 at 7:59
  • 1
    $\begingroup$ FWIW, for me (Firefox 89 on Linux) the line breaks display correctly with most Math Renderer settings (including the default “HTML-CSS”), with the exception of “Preview HTML” and “MathML”, which make it look similar to your screenshot. $\endgroup$ Jun 3, 2021 at 8:05
  • $\begingroup$ @EmilJeřábek I tried at several different expressions of various sizes. When I hover over it, occasionally the cursor changes from an arrow to a vertical line, but in any case when I right click I just get the default Firefox menu that appears upon the right click anywhere else. $\endgroup$ Jun 3, 2021 at 8:14

2 Answers 2


Inspired by helpful comments and answer, I found the reason. I had the Native MathML Firefox add-on installed, I switched it off and everything renders correctly now, also I can access the MathJax menu.

In fact this seems to be a bug in that add-on known from March 2020.


It appears to be about inability of firefox@windows to handle explicit \\ in displayed maths - you can look at the source of the Integral representation of product of two Whittaker functions question you are talking about.

I also see that it works just fine in firefox@linux (Firefox version 87.0).

(It's not some kind of automatic wrapping broken, it's more basic)

Edit: it was pointed out that it's invalid LaTeX in that equation, so this can be closed.

  • $\begingroup$ Not surprising, given that Windows treats `\` differently, contributing to driving developers to insanity quite a lot :-) $\endgroup$ Jun 3, 2021 at 11:44
  • 2
    $\begingroup$ Your answer gave me an idea. I edited that question and replaced the $$ with \begin{multline*} \end{multline*} (without touching the \\ ). It renders correctly in the preview. $\endgroup$ Jun 3, 2021 at 11:45
  • $\begingroup$ Besides, it is still not clear why I cannot access the MathJax menu $\endgroup$ Jun 3, 2021 at 11:47
  • $\begingroup$ In my Firefox I can do this --- switch to Linux :P $\endgroup$ Jun 3, 2021 at 11:49
  • $\begingroup$ Well I've got WSL. Maybe one day I'll migrate without even noticing it :) $\endgroup$ Jun 3, 2021 at 11:50
  • $\begingroup$ I suggest WLS 2, not 1 - just in case. $\endgroup$ Jun 3, 2021 at 12:03
  • $\begingroup$ Probably I should have explicitly mentioned that screenshot I posted above was from Firefox under Windows. $\endgroup$ Jun 3, 2021 at 12:19
  • $\begingroup$ Oh dear, I didn’t notice that there were \\ inside $$...$$ without any proper environment. This is basically invalid syntax, and it is not supposed to work. (In actual LaTeX, it doesn’t produce a line break.) You seem not to have submitted the edit, so I will. $\endgroup$ Jun 3, 2021 at 12:56
  • $\begingroup$ @EmilJeřábek It is clear that this is not correct in LaTeX. Whether or not this is suppose to work in MathJax is a separated question. There are a few related comments and links in the MathJax chatrom. $\endgroup$ Jun 5, 2021 at 6:40
  • $\begingroup$ @MartinSleziak I see, I wasn’t aware of that. Usually, MathJax strives to be compatible to LaTeX, so this is an odd exception. $\endgroup$ Jun 5, 2021 at 8:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .