12
$\begingroup$

Recently, every time I visit Mathoverflow, I get a popup asking me to allow cookies. I have nothing against this in principle, but might there be a way that lets me respond and be done with it instead of having this pop up every time?

$\endgroup$
4
  • $\begingroup$ And it's only MathOverflow, not other stacks. $\endgroup$ – Buzz Mar 31 at 3:31
  • 5
    $\begingroup$ I'm getting it on all SE sites. I can block it on MO by adding mathoverflow.net##.js-consent-banner.r16.l16.b16.bar-lg.fc-white.bg-black-750.p32.sm\:w-auto.ws4.z-nav-fixed.ps-fixed.ff-sans to my uBlock Origin filter list, but I don't know a solution that works uniformly across SE sites. $\endgroup$ – Peter McNamara Mar 31 at 4:09
  • 4
    $\begingroup$ This is due to meta.stackexchange.com/q/359358. There are several reports of users for whom the dialog does not remember the settings or otherwise misbehaves, such as meta.stackexchange.com/q/359691. It seems one cause might be that the browser blocks third-party cookies for security reasons (which is a good thing to do; IOW, the design with off-sourcing the dialog to a third party is a stupid idea). Anyway, based on the comments, the only solution that works now seems to be to kill the dialog with an ad blocker. $\endgroup$ – Emil Jeřábek Mar 31 at 7:31
  • 3
    $\begingroup$ I got the dialog twice, and then never again. When you agree, it is not supposed to return next time. But (as noted in the question) that does not always work. $\endgroup$ – Gerald Edgar Mar 31 at 11:22
-1
$\begingroup$

If You are using Chrome there is a really good extension called Cookie Notice Blocker. It works for most sites so it probably also works on mathoverflow.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .