5
$\begingroup$

Starting last night I can no longer see comments when using the site on my iPhone, nor can I comment. Things are fine on my iPad just not my iPhone. I am wondering if anybody else has ever had this problem or is having this problem. I presume I accidentally changed some setting but I have no idea how to get commenting back. I have tried logging back in and out of mathoverflow but it didn't help. Since I mostly use the site on my phone, this is a bit irksome.

added: Even stranger, I can see comments on other stackexchanges sites.

added: it seems the problem is only in Safari since in Chrome it works.

$\endgroup$
  • $\begingroup$ What version of iOS do you have (on both devices)? $\endgroup$ – Glorfindel Jan 11 at 12:52
  • $\begingroup$ @Glorfindel I'm using 14.3 for both $\endgroup$ – Benjamin Steinberg Jan 11 at 12:55
  • $\begingroup$ Right. That's the newest version (it's known that the site doesn't work on very old iOS versions, hence I asked). $\endgroup$ – Glorfindel Jan 11 at 12:58
  • $\begingroup$ @Glorfindel, I can see comments on the tex and MSE sites. Just not on mathoverflow and mathoverflow-meta $\endgroup$ – Benjamin Steinberg Jan 11 at 12:59
  • 2
    $\begingroup$ Are you using: (a) mobile view; (b) full site in responsive design; (c) full site without responsive design; also important is the phone vertical or horizontal (and rotated view, of course)? $\endgroup$ – Asaf Karagila Jan 11 at 13:33
  • $\begingroup$ @AsafKaragila, I tried both vertical and horizontal but it didn't make a difference. I suspect it is mobile view but I never had this issue before and as I said it seems fine on the other stackexchange sites $\endgroup$ – Benjamin Steinberg Jan 11 at 14:13
  • $\begingroup$ @AsafKaragila, how do I turn off mobile view $\endgroup$ – Benjamin Steinberg Jan 11 at 14:16
  • 2
    $\begingroup$ Scroll to the bottom of this page, you should see "full site", upon switching you will also see there "disable/enable responsiveness". $\endgroup$ – Asaf Karagila Jan 11 at 14:21
  • 1
    $\begingroup$ @AsafKaragila, I tried full site and disabled responsiveness and still don't see the comments $\endgroup$ – Benjamin Steinberg Jan 11 at 14:34
  • $\begingroup$ @AsafKaragila, I also don't see the link for add comment $\endgroup$ – Benjamin Steinberg Jan 11 at 14:34
  • 1
    $\begingroup$ That is indeed very odd. I don't really know iPhone, but can you use a different browser/disable ad blocking features/try incognito mode? $\endgroup$ – Asaf Karagila Jan 11 at 14:47
  • $\begingroup$ @AsafKaragila, if I log out and view the site then I see comments on questions other than my own. I am not sure how to do incognito mode. I'll try another browser $\endgroup$ – Benjamin Steinberg Jan 11 at 14:51
  • $\begingroup$ Normally it's in the option, "private browsing" or when you create a new tab. $\endgroup$ – Asaf Karagila Jan 11 at 14:53
  • 1
    $\begingroup$ My general suggestion is to ditch Apple altogether. But it might not be a practical one at this point. But it certainly means that the problem is somewhere in your settings. Since I don't use iPhone, I can't quite help you further... :\ $\endgroup$ – Asaf Karagila Jan 11 at 14:54
  • 2
    $\begingroup$ Works fine in my Safari on iPhone. (Asaf if you want me to give up Apple convince any other phone manufacturer to make a hand-sized phone! The iPhone mini is literally the only thing in its market!) $\endgroup$ – Noah Snyder Jan 11 at 17:38

You must log in to answer this question.

Browse other questions tagged .