2
$\begingroup$

When looking at a question, for at least the past few months I've noticed an inconsistency in what displays in the righthand sidebar. What I expect to see is a list of "related questions" -- first the ones linked from the question I have open, followed by others that the software thinks are relevant. I can't get an example to screenshot right now, but this functionality has been around as long as I can remember and I hope folks know what I'm talking about. One potentially relevant fact is that on many Stack Exchange sites, there are ads here or links to questions on yet other Stack Exchange sites, but I believe MO has been fairly unique in always having just links to other questions on MO here.

But sometimes (and maybe with increasing frequency?) this list of questions fails to show up, and instead I just get the text "Question feed" with the little RSS icon next to it. (EDIT It looks like "Linked Questions" are showing up for me, but not "Related Questions".) Here's a screenshot:

enter image description here

(See what I mean on the lower righthand side?)

When I click on it, it says something about setting up an RSS feed:

enter image description here

I suppose I'm some kind of Neanderthal, but I've never felt the need to set up an RSS feed, I don't know how they work, and I don't understand why I should need to just to see the related questions for a question I'll probably look at once and never come back to. Neither refreshing nor turning off my adblocker seem to make a difference. I use Chrome on Windows 10.

Does this happen to others? Is it a feature or a bug? Is there something I can do to fix it?

I did find a meta question listing RSS feeds related to Stack Exchange but as far as I can tell none of them seem to be related to this.

| |
$\endgroup$
  • 2
    $\begingroup$ Google effectively killed RSS when they got rid of google reader in 2013, and the internet has gotten steadily worse ever since. $\endgroup$ – Noah Snyder Aug 30 at 22:27
  • 4
    $\begingroup$ @TimCampion As for the "Related Questions" section, that used to basically always be there, except for a while a few weeks back when there were none for any questions, and for the past about 3 weeks for any new questions. Note I ask about this latest issue in my main Meta post The "Related" section in the right sidebar is now completely missing for new questions. I trust this issue will be fixed soon so the "Related" questions section will then be showing for questions from the past 3 weeks & for all new ones from then on. $\endgroup$ – John Omielan Aug 31 at 0:09
  • $\begingroup$ @JohnOmielan Ah, thanks. If I had noticed earlier that it was just the related questions not showing, and only for "new" posts, I'd like to think I could have found your question and avoided adding this duplicate. $\endgroup$ – Tim Campion Aug 31 at 0:11
  • $\begingroup$ I tried to vote to close, but I can't seem to find your question when I search in that interface. Maybe I should delete? Oh I see -- your question was on the general SE meta, not MO meta. $\endgroup$ – Tim Campion Aug 31 at 0:20
  • 1
    $\begingroup$ It is wroth mentioning that the RSS feed is not a feed with related question - but it is a feed for new answers to that specific question. You sometimes visit MO editors' lounge. You can see that there are two questions feeds in that chatroom and also check posts from those feeds: chat.stackexchange.com/search?room=10243&q=194&user=-2 and chat.stackexchange.com/search?room=10243&q=862&user=-2 $\endgroup$ – Martin Sleziak Aug 31 at 7:01
  • $\begingroup$ It seems like this question is a more canonical version of the issue -- it's claimed that the issue was resolved by July 30, but many people have commented that it's still an issue since then. $\endgroup$ – Tim Campion Aug 31 at 19:51
  • 2
  • 1
    $\begingroup$ Note to self: next time there seems to be a bug, check to see whether it is a wider SE issue before posting to MO meta. $\endgroup$ – Tim Campion Sep 3 at 22:20
  • $\begingroup$ @TimCampion It seems quite likely that many MO users only follow the local meta and not Meta Stack Exchange. For such users, it might be useful that something about some recent bug is mentioned in local meta - they can at least find out what that something is going on. $\endgroup$ – Martin Sleziak Sep 4 at 13:52
2
$\begingroup$

As Martin points out in the comments, this issue has been marked resolved in the Meta SE question. And indeed, I do see related questions appearing even for new questions now. I believe the "Question feed" link was a red herring: it is simply the next thing that appears below "Related Questions" but I apparently rarely notice it when "Related Questions" are working properly.

My one lingering concern is that it kind of looks to me as though there are now fewer related questions appearing on a given question page, compared with with what I'm used to. But I might be mistaken.

| |
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .