3
$\begingroup$

This happens with Every mathematician has only a few tricks: the link with the author username leads to the revision history. I checked several other questions, including some cw (this one is cw), only this one has it.

$\endgroup$
17
  • 5
    $\begingroup$ See e.g. mathoverflow.net/a/361870 for an older example. The behaviour seems to be that in a CW post, if an answer was written only by one user, it displays their user name linked to the revision history, whereas if there are revisions by multiple users, it displays “X revs, Y users Z%” linked to the revision history, and a user name (of the user who contributed most) linked to their profile. The question you linked to is special in that it is very recent, hence no answer was edited by more than one user. $\endgroup$ Commented Jun 16, 2020 at 6:29
  • $\begingroup$ @EmilJeřábek Clever! So it really is a bug then? $\endgroup$ Commented Jun 16, 2020 at 7:14
  • 2
    $\begingroup$ I’d say so. If it is intentional design decision, it is quite confusing and inconsistent. (Apart from the links, also the “Z%” logically belongs to the next line to the user name.) $\endgroup$ Commented Jun 16, 2020 at 7:26
  • $\begingroup$ @EmilJeřábek Could it be something recent? 23 hours ago some of my entries got hit by something named Commonmark migration. One of these displays the above behaviour. $\endgroup$ Commented Jun 16, 2020 at 7:31
  • 1
    $\begingroup$ CommonMark migration is this. There is no reason for this to affect page design. $\endgroup$ Commented Jun 16, 2020 at 8:03
  • $\begingroup$ @Emil Right, thanks. Seems to have nothing to do with my question. $\endgroup$ Commented Jun 16, 2020 at 8:13
  • 5
  • 3
    $\begingroup$ Interestingly, this post is marked (status-completed): User names on community wiki posts should link to profile pages (like they do everywhere else). But the comments explain that it does not work if the CW post haven't been edited. $\endgroup$ Commented Jun 16, 2020 at 8:44
  • 1
    $\begingroup$ @EmilJeřábek I might have missed something, but in the CW posts that I have tried, I get to the user profile even if there was only one user, if that user has at least one edit. So if a CW post has only initial revision (and no subsequent edits), then it goes to revision history. If there was at least one edit, the link goes to the user profile. (It does not matter whether the subsequent edit was done by the same user or by a different user.) $\endgroup$ Commented Jun 16, 2020 at 9:27
  • 1
    $\begingroup$ @MartinSleziak Can you give an example? This post or this post were edited, but the links go to the revision history. $\endgroup$ Commented Jun 16, 2020 at 9:50
  • 2
    $\begingroup$ Aha, some of the answers here behave that way. Perhaps the actual criterion is if the post was edited after it became CW. (The two examples in my previous comment were only edited before the question was made CW.) $\endgroup$ Commented Jun 16, 2020 at 10:07
  • 1
    $\begingroup$ By the way, as @MartinSleziak's links show, this behaviour is not new. I've noticed it for several years, and always assumed it was an intentional (but confusing) design decision. $\endgroup$
    – LSpice
    Commented Jun 17, 2020 at 12:57
  • 1
    $\begingroup$ I didn't mean to defend the behaviour (there are a lot of intentional design decisions here that I don't like!), only to respond to the suggestion that maybe this was a recent change. $\endgroup$
    – LSpice
    Commented Jun 17, 2020 at 13:53
  • 1
    $\begingroup$ @LSpice I see, thanks for the clarification. $\endgroup$ Commented Jun 17, 2020 at 14:16
  • 2
    $\begingroup$ @მამუკაჯიბლაძე: This is a years-old behaviour for CW posts. I suspect it is intended to be so, although I (like you and others) find it really confusing. Bad design, not bug. $\endgroup$
    – Alex M.
    Commented Jun 19, 2020 at 9:49

0

You must log in to answer this question.

Browse other questions tagged .