I'm not sure if this question is appropriate for MOmeta, but as the tool had been suggested for offline editing, I'll give it a try (please vote to close if not appropriate).

Stackedit got updated in the last few days and since then it exhibits strange behavior (maybe a fault from my side as user): when using firefox, only a blank page appears in editing mode:
Stackedit 5 in writing mode with Firefox

when using the Windows explorer, then editing and WYSIWYG display aren't in sync anymore and changes are not saved:
Stackedit 5 in writing mode with Windows Explorer

have others tried the new version yet and can give hints of what goes wrong?

  • $\begingroup$ I will at least mention that Stackedit was recommended by François G. Dorais♦ in this answer as an editor which can be used to prepare posts not directly on the MO website. (Mainly because many users might wonder whether this is related to MO in any way.) $\endgroup$ Jan 18, 2018 at 7:01
  • $\begingroup$ I am not sure whether there are some other sites where something like this would be on-topic (and possibly with better chance of finding somebody able to answer). I was able to find that there is stackedit tag on Web Applications site - but so far only 3 questions were posted with this tag. $\endgroup$ Jan 18, 2018 at 7:06
  • 1
    $\begingroup$ I am not able to reproduce the problems you have. Do I have to somehow turn on the newer version of StackEdit that you mention? I have also asked in Webapps.SE chat whether something like this would be on-topic there. The response I got is somewhat ambivalent. $\endgroup$ Jan 18, 2018 at 21:40
  • 1
    $\begingroup$ @MartinSleziak: I had my browser cache and offline webpages cleaned so that the newest version of Stackedit was loaded (previously I got the message, that a new version of Stackedit is available); meanwhile I verified the behavior on my side with windows10 64bit on 3 computers and on Windows7 32bit and also with different virus scanners installed. $\endgroup$ Jan 19, 2018 at 6:14
  • 2
    $\begingroup$ @MartinSleziak: Followup a colleage didn't observe the problem; so I completely uninstalled FireFox, reinstalled it and let it delete all saved settings; that solved the problem (with FireFox). Generally the problem only seems to appear with stackedit.io/app but not with stackedit.io/editor (the second being the "old" version). $\endgroup$ Jan 19, 2018 at 6:53
  • $\begingroup$ I will just confirm that when I tried this another browser - in which I previously have not used StackEdit - I experience problems too. stackedit.io/editor seems to be working find, but in stackedit.io/app nothing gets rendered in the preview pane. Unfortunately, I do not have any good advice what could solve the problem. (Maybe reporting the problems here might be worth considering: github.com/benweet/stackedit/issues ?) $\endgroup$ Jan 24, 2018 at 21:44


You must log in to answer this question.

Browse other questions tagged .