7
$\begingroup$

Did ArXiv trackbacks stop working for MathOverflow, or does the ArXiv server generally suffer from some issues, maybe related to the planned/ongoing modernization of the service?

From looking at the most recent 100 trackbacks, you can see that very few got posted recently (the last one for MO occured on September 29th) and since October 8th the trackbacks stopped alltogether

https://arxiv.org/tb/recent

For example, this recent answer which cites an ArXiv paper did not trigger a trackback

https://mathoverflow.net/a/251687/30967

Does anybody have some insights about what is currently going on with the ArXiv trackbacks? Are there some technical issues or did they reconsider their list of trusted sites and remove MO (and many others) for some reason?

I strongly suspect that the issues are on the ArXiv side if any, even though nobody else seems to be complaining about troubles with ArXiv trackbacks ...

$\endgroup$
  • $\begingroup$ Isn't this rather an ArXiv question than a question about MathOverflow? $\endgroup$ – Stefan Kohl Oct 10 '16 at 12:28
  • 1
    $\begingroup$ @StefanKohl yes, but maybe the people who have written the script for MO to get the trackbacks posted (Scott Morrison if I remember this correctly?), might have some insights too and could probably contact the ArXiv (in a more official way than I could do) if there are indeed some issues? $\endgroup$ – Dilaton Oct 10 '16 at 12:32
  • 5
    $\begingroup$ @StefanKohl trackbacks to MO are important, as they allow authors of ArXiv papers that get cited on MO to see that there is a discussion about their work here which might be of interest to them. If the mechanism is broken at present for some reason, this should get fixt. I dont see the usfulness of trying to mark an actual bug report as a duplicate of a resolved bug report, if the issue occurs again and most probably for different reasons than in the past. Note that ArXiv trackbacks are a nice extra feature of MO, such that reporting this bug on Meta SE would not help anything ... $\endgroup$ – Dilaton Oct 10 '16 at 13:20
8
$\begingroup$

I've updated the MathOverflow script to use https, and set it to re-run on posts modified since September 29.

Thanks for the notification of the problem, and the solution from @Dilaton.

$\endgroup$
  • 2
    $\begingroup$ And the missing trackbacks have all appeared! $\endgroup$ – Scott Morrison Oct 13 '16 at 2:39
8
$\begingroup$

I have to admit that I initially got aware of the since September 29th 2016 missing trackbacks for MO, because we at PhysicsOverflow faced the same issue.

Now I am happy to report that our system developer resolved the issue after learning from communications with the ArXiv that they changed the protocol for trackbacks from http:// to https://, and now uses an SSL connection.

Maybe someone (@ScottMorrison?) is soon able to adapt the code used by MO accordingly which will most probably solve the problem?

Hope this will help

$\endgroup$
  • 4
    $\begingroup$ I'm guessing PO is Physics Overflow, but you cannot expect readers here to know that. $\endgroup$ – Gerald Edgar Oct 11 '16 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .