At the request of the moderators, we have added a citation helper (based on the citation helper user script by Scott Morrison).

citation helper editor button

If you are familiar with the original script, you will note a few differences - these were done as part of integration and as result of a security review. Notably, the script will not automatically search a highlighted term and there is no inline preview.

If you are still using the user script - it might clash with this one, so I suggest removing the user script.

Oh. And it got its own icon...

Please post any bugs/comment here.

  • 5
    $\begingroup$ Awesome. Awesome to the max. $\endgroup$ – Asaf Karagila Nov 20 '15 at 14:17
  • $\begingroup$ (How many people except for me were actively using the original script, by the way? Please vote this comment if you were one of them.) $\endgroup$ – Asaf Karagila Nov 20 '15 at 14:18
  • 3
    $\begingroup$ I guess that link to the post about the original script should be mentioned: meta.mathoverflow.net/questions/1485/… $\endgroup$ – Martin Sleziak Nov 20 '15 at 15:22
  • 1
    $\begingroup$ @AsafKaragila I was activiely using the original script at first, but then it stopped working for me shortly after it was available, when there was some kind of upgrade if I recall, and I haven't used it since then. $\endgroup$ – Joel David Hamkins Nov 21 '15 at 12:08
  • $\begingroup$ Wow - this means free Mathscinet search access for everyone on the planet? How did you get the AMS agree to this without fear of getting out of business? $\endgroup$ – Federico Poloni Nov 23 '15 at 5:04
  • $\begingroup$ @FedericoPoloni We don't provide review access. AMS Math Reviews does provide this for everyone via MRef and MR lookup. $\endgroup$ – François G. Dorais Nov 23 '15 at 18:24
  • 1
    $\begingroup$ Perhaps the new script is related to these two mathjax bugs? (Both bugs aren't reproducible on meta.) meta.mathoverflow.net/questions/2596/… meta.mathoverflow.net/questions/2600/formatting-problem $\endgroup$ – François G. Dorais Nov 23 '15 at 18:30
  • $\begingroup$ @FrançoisG.Dorais - I very much doubt that and cannot reproduce. If anyone who can reproduce would post whether they get any javascript errors on the page (F12 should bring up developer tools that will display any such errors), that would help with debugging/fixing (and ascertaining where the problem is). $\endgroup$ – Oded Nov 23 '15 at 18:49
  • $\begingroup$ I can reproduce both bugs but I didn't find any javascript errors. Did anything else change with the preview? I can't think of anything else that happened with the preview on main and not on meta. $\endgroup$ – François G. Dorais Nov 23 '15 at 19:27
  • $\begingroup$ Thing is - the citation helper doesn't have much to do with the preview (in particular if you don't use the script - don't click the button). It does call MathJax and requests a preview refresh, but only after selecting a citation. I am still trying to reproduce. $\endgroup$ – Oded Nov 23 '15 at 19:38
  • $\begingroup$ @FrançoisG.Dorais - I don't believe anything else changed on our end. I am on Windows, and trying with both Chrome and FireFox, but can't reproduce the issue. $\endgroup$ – Oded Nov 23 '15 at 19:43
  • 1
    $\begingroup$ I just reproduced both bugs on OSX with chrome & safari and on Windows 7 with chrome and firefox. To get both bugs at once type $\{1,2,3\}$ and weak$^*$ on $Z^*$ and compare the preview on main with "$\{1,2,3\}$ and weak$^*$ on $Z^*$". $\endgroup$ – François G. Dorais Nov 23 '15 at 19:57
  • 2
    $\begingroup$ OK. Found the issue, fix is en-route. Had to do with how I integrated the scrpit with the editor. //cc @FrançoisG.Dorais $\endgroup$ – Oded Nov 23 '15 at 20:50
  • 1
    $\begingroup$ Moderators, could you "feature" this so it appears on the MO front page? $\endgroup$ – Nick Gill Nov 25 '15 at 12:05
  • 3
    $\begingroup$ In an effort to help promote this feature, I wrote about the citation helper on my blog, and included a worked example. You can find the post here. $\endgroup$ – Edward Dunne Apr 21 '16 at 13:14

Maybe nobody else is as clumsy as I, but when I first tried this I though it does not work for me, as I did not realize I need to press "enter" to submit the query.

I guess my confusion is due to the fact that other fields that look like that (tag-search, user-search) do start automatically.

Would it be possible to have a (preselected) button next to that line, or some other indication on needs to press "enter"?


It seems to have some trouble with some non-ASCII characters (but not all). For example trying to cite this entry yields:

Pascal Lambrechts and Ismar Voli?, Formality of the little $N$-disks operad, Mem. Amer. Math. Soc. 230 (2014), no. 1079, viii+116.

Notice how the second author's name is incorrect: it should be "Volić". The character is formatted as {\'c} in the bibtex source. (Some other non-ASCII characters seem to work fine like éèà).

  • $\begingroup$ The citation data goes through a few different sources - from what I can tell, the script just picks up what it is given, so the issue is either at the citation service or at where it sources the citation data. $\endgroup$ – Oded Nov 21 '15 at 9:37
  • 4
    $\begingroup$ @Oded The source data from mathscinet is correct, it just needs to be translated into unicode correctly. As far as I can tell from the source, everything after that is handled by mathoverflow. The problem is already present when looking up something using this. $\endgroup$ – Najib Idrissi Nov 21 '15 at 10:36
  • 1
    $\begingroup$ Yes, that's the service end point - something on that end. This is outside of the control of Stack Exchange. $\endgroup$ – Oded Nov 21 '15 at 11:47
  • 1
    $\begingroup$ Even though it’s 2015 and Unicode has been here for like quarter of a century, there is a plenty of broken legacy technology out there that treats ISO-8859-1 characters as more equal than others. Seeing the examples of characters that do and don’t work, this might be related to the problem here. (Also, that this might read a bit like a rant is related to the character repertoire in my name.) $\endgroup$ – Emil Jeřábek supports Monica Nov 25 '15 at 18:56

The formatting of the citation output is a bit odd.

Joan Bagaria and Menachem Magidor, MR 3226024 On $\omega_1$-strongly compact cardinals, J. Symb. Log. 79 (2014), no. 1, 266--278.

The MR reference should be at the end, or at least not between the authors and the title. And while we're at it, we can also add a direct link to this by using http://www.ams.org/mathscinet-getitem?mr=[MR#]

  • $\begingroup$ Asaf, I'm going to hold off on this, as it seems likely we will move to producing links to Zentralblatt rather than MathSciNet. (If anyone is interested in the details, I'm happy to discuss via email or meta. It's still a (very slow) work in progress.) $\endgroup$ – Scott Morrison May 3 '16 at 23:49
  • $\begingroup$ My former commander used to quote his grandmother: temporary things are permanent. :-) $\endgroup$ – Asaf Karagila Nov 22 '16 at 7:18
  • $\begingroup$ The relevant snippet of code is function getCitationHtml(json) in cdn.sstatic.net/js/third-party/citation-helper.js?v=2, and the json you have available is as in this example. If you'd like to propose a better version, I'm happy to test it and ask to have it deployed. $\endgroup$ – Scott Morrison Dec 8 '16 at 3:22

I just stumbled over this, and have no idea what it does, and how to use it. So far, all I managed to achieve was that it shows me an animation (three "pulsating" dots), and nothing happend.

Also, it is not mentioned under "Help" nor under "Advanced help" either. It would be really great if there could be at least some minimal documentation.

UPDATE: seems this is broken because the TLS certificate for https://ec2.mathoverflow.org expired end of october.... so I guess three things would be nice to have:

  1. a new certificate;
  2. an automated renewal mechanism for it;
  3. an improvement to the JavaScript code to detect connection failures and then change the progress animation to an error mssage...
  • $\begingroup$ Thanks! I've fixed the certificate, and ensured that it will be renewed automatically. (By moving to Let's Encrypt and running certbot.) However I seem to have broken something else at the same time, which I'm now working on. $\endgroup$ – Scott Morrison Nov 22 '16 at 22:25
  • $\begingroup$ @Scott: Is the certificate broken again? It seems to be searching for "a long time" without any results queries that returned citations in the past. $\endgroup$ – Asaf Karagila Nov 30 '16 at 13:15
  • $\begingroup$ Using the web inspector in FireFox (or the equivalent tools in other browsers reveals that the citation helper tries to access ec2.mathoverflow.org/… and that in turn gives a "502 Proxy Error" $\endgroup$ – Max Horn Nov 30 '16 at 14:39
  • $\begingroup$ If the code for this thing was online somewhere, other people could help with the development... as it is, it is rather opaque how it works :/ $\endgroup$ – Max Horn Nov 30 '16 at 14:40
  • $\begingroup$ Sorry, the certificate is fine, the underlying engine is broken. I'm struggling to find the time, but am hopeful about the end of the week. I will certainly attempt to make it possible for others to help. $\endgroup$ – Scott Morrison Dec 4 '16 at 21:39
  • $\begingroup$ Everything is working again. The problem was a memory limit on the server, which I've raised. $\endgroup$ – Scott Morrison Dec 8 '16 at 3:21
  • $\begingroup$ @ScottMorrison Can other sites, like CSTheory.SE where I'm a moderator, also get the citation helper? How would we go about that? $\endgroup$ – Bjørn Kjos-Hanssen Aug 23 '18 at 5:32
  • $\begingroup$ @BjørnKjos-Hanssen, the citation helper is back by Zentralblatt's database, so you would need to determine if their coverage of theoretical computer science was sufficient for your needs. If so, the endpoints is a public API (limited to returned 3 results per query), and so I think you'd just need to ask the Stack Exchange team to activate the same piece of javascript in the front end as we use. $\endgroup$ – Scott Morrison Aug 25 '18 at 13:26
  • $\begingroup$ @ScottMorrison thanks, and sorry for the ignorance but what's the best way to "ask the Stack Exchange team"? $\endgroup$ – Bjørn Kjos-Hanssen Sep 17 '18 at 4:36
  • $\begingroup$ @BjørnKjos-Hanssen, perhaps email community@stackexchange.com? It's probably worth mentioning you're a moderator, to increase the chance they notice your message! $\endgroup$ – Scott Morrison Sep 17 '18 at 8:45
  • $\begingroup$ @ScottMorrison it worked! $\endgroup$ – Bjørn Kjos-Hanssen Sep 22 '18 at 2:20

Here is a mild (known) issue that can be easily fixed. In some places \ssf is used instead of \mathsf. This should be easily fixable.

  • 3
    $\begingroup$ This is something to be fixed on the data source for the citations - the script pretty much picks up that unchanged. $\endgroup$ – Oded Nov 20 '15 at 14:21

It seems the citation helper only covers journal papers, but ignores books, even if MathSciNet has them. Intentional?


Has the citation helper been disabled? When posting an answer just now, I did not see the icon.

  • $\begingroup$ Nope, shouldn't have. A bunch of images were moved - could be that (if so, clicking on the empty space should work). Will look when I am a dev machine (probably tomorrow). $\endgroup$ – Oded Mar 31 '16 at 19:30
  • $\begingroup$ Aha! I hovered over the empty space just now and a pop-up "Insert Citation Ctrl-M" appeared. I need to get better at using invisible buttons! Note: the button is only invisible when I use Chrome. On Safari, it is present. I haven't checked other browsers. Thank you for the help. $\endgroup$ – Edward Dunne Mar 31 '16 at 19:38
  • $\begingroup$ No problem - I will fix it when my workday starts ;) $\endgroup$ – Oded Mar 31 '16 at 19:46
  • $\begingroup$ The earlier version of the Citation Helper added the link to the MathSciNet entry for the article. Is there any chance that you could enable that? $\endgroup$ – Edward Dunne Apr 8 '16 at 17:51
  • $\begingroup$ I just realized that the link to the MathSciNet is in there. The title is a live link to the MathSciNet entry for the item. Thank you @Oded♦. $\endgroup$ – Edward Dunne Apr 14 '16 at 14:57
  • 2
    $\begingroup$ I wrote about the citation helper on my blog, and included a worked example, here. $\endgroup$ – Edward Dunne Apr 18 '16 at 20:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .