2
$\begingroup$

When I try to ask new questions, the "autocomplete features" don't work (in Firefox ESR 31.3.0):

  • When I start typing a title, I don't get a list of existing titles.
  • I don't see a preview of my question below the text input field.
  • I don't get any tag suggestions when I start writing in the tag field.

These features do work when I edit an existing question or give an answer. Asking questions works normally if I use IE instead of Firefox (as I'm doing now) and it used to work with Firefox, too.

I don't quite understand how this behavior is possible. How are the features I mentioned above implemented and what is the difference between the implementations for asking and answering/editing? What causes the problem with asking with Firefox and what can I do about it?

I suppose I could first ask the question in some form and then edit it to gain access to the features I want, but this would produce empty or half-complete questions with misspelled tags while I'm in the process of polishing my post. And this is clearly not the way questions are supposed to be asked.

$\endgroup$
  • 1
    $\begingroup$ This kind of error typically means that the SE javascript is not working for some reason. You could try clearing your browser cache, disable any extensions that might block javascript (NoScript and similar ones) and check the developer console for any javascript errors. My personal guess would be a corrupted cache, so I'd try clearing the cache first. $\endgroup$ – Mad Scientist Dec 20 '14 at 14:14
  • $\begingroup$ @MadScientist, I cleared the cache. I have no such extensions; the SE javascript does work for edits and answers. Despite clearing the cache (Firefox told that there were no cache files left) and restarting the browser, the problem persists. The console gives the same error message as before this operation: "NS_ERROR_FILE_CORRUPTED: File error: Corrupted". This error only comes on the "ask question" page. $\endgroup$ – Joonas Ilmavirta Dec 20 '14 at 16:32
  • $\begingroup$ Maybe this is a network profile sync issue. This computer is owned and managed by my university, and my local profile attempts to sync with my university network profile although I'm outside the network. (This is presumably the reason for the browser history not working properly lately. Even connecting to the university network usually doesn't resolve this kind of issues, though.) Nevertheless, I don't understand getting the corrupted file error and being told that there is no cache. $\endgroup$ – Joonas Ilmavirta Dec 20 '14 at 16:37
  • $\begingroup$ NS_ERROR_FILE_CORRUPTED indicates corruption of the browser cache, and this is not necessarily fixed by clearing it in the usual way. Several online sources suggest to delete the webappsstore.sqlite file in the Firefox profile directory and restart the browser (it will then recreate the file). See also developer.mozilla.org/en-US/docs/Web/Guide/API/DOM/… . $\endgroup$ – Emil Jeřábek supports Monica Dec 20 '14 at 17:02
  • $\begingroup$ Or actually, the corrupted file could be just about anything in the profile. Doesn’t the error message give more details? $\endgroup$ – Emil Jeřábek supports Monica Dec 20 '14 at 17:28
  • $\begingroup$ @EmilJeřábek, the console gives that error message and this location: cdn.sstatic.net/Js/full.en.js?v=207a95000ab6. My attempts to fix the problem made the title thingy work, but the others still don't work. My profile folder appears not to contain a webappsstore.sqlite file or any history information. (The profile situation is messy. For example, clearing browsing history doesn't seem to have any effect: the history isn't removed but it still isn't updated when I go to new sites.) I fear that the problem can only be resolved by contacting my system administrator after the holidays. $\endgroup$ – Joonas Ilmavirta Dec 20 '14 at 18:59
  • 1
    $\begingroup$ Contacting the system administrator is probably the right thing to do. However, what you can try meanwhile is to create a fresh Firefox profile using the profile manager (you seem to be on Windows: kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows), and use it instead of the possibly corrupt default profile. $\endgroup$ – Emil Jeřábek supports Monica Dec 20 '14 at 19:14
2
$\begingroup$

The problem (and other little problems on different sites) resolved itself when I cleared the cache of my tabletop computer at the university and then connected my laptop to the university network and let it update itself. Maybe the problem was that my laptop was trying to synchronize with my user profile at the university (my "main profile" as opposed to my "local profile" on the laptop) and something in the "main cache" was wrong. This is a bit weird since I did not have similar problems with the tabletop in my office. Anyway, it works now. Thanks for all the support!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .