8
$\begingroup$

When I type a search into the search box, sometimes the list of questions returned contains incorrectly handled TeX (of the sort that once was common all over the place here).

Here is an example: http://www.math.uiuc.edu/~rezk/mo-bug-exam.png. The third question in the list is especially bad, but note that "\lambda" and "\Lambda" are not being converted in some of the other questions. The actual questions are correctly displayed on their own page.

$\endgroup$
  • 3
    $\begingroup$ I suppose your search terms (in particular, all instances of lambda) are highlighted in the result of the search, which interferes with their rendering by Mathjax. $\endgroup$ – Emil Jeřábek supports Monica Jul 28 '14 at 22:20
  • 2
    $\begingroup$ And the reason for the rest of the mess is that the partial snippets of text taken from the original posts happen to have unbalanced dollar signs. In short, the search facility is apparently unaware that $ has a special meaning. $\endgroup$ – Emil Jeřábek supports Monica Jul 28 '14 at 22:30
  • $\begingroup$ @Emil: I suspect the second comment is the truer reason. $\endgroup$ – Asaf Karagila Jul 29 '14 at 0:02
  • $\begingroup$ @AsafKaragila: What do you mean by truer? There are two issues with two reasons. Both are obvious from the HTML source. $\endgroup$ – Emil Jeřábek supports Monica Jul 29 '14 at 9:08
  • 4
    $\begingroup$ This is a known bug which apparently is not easy to fix. $\endgroup$ – Logan M Jul 29 '14 at 22:00

You must log in to answer this question.

Browse other questions tagged .