2
$\begingroup$

I am using a Droid2 phone with mobile browser version 2.3.4. Most of the time I can display items on MO, meta, and related sites reasonably well, even the full site versions.

A few minutes ago, I attempted question 22 (squares with only 0 and 1 as base ten digits), and that closed the browser app suddenly, after displaying some of the page briefly.
I can view other questions, as well as what I can see of the question from the search dialogues and revisions tab, but not (for long) the desired page.

Short of installing a new browser, does anyone know what could be done to fix this? Also, why should a browser abort occur in the first place?

This is the first time I have seen this behaviour on StackExchange sites where I can point to a specific page to repeat the problem.

$\endgroup$
  • $\begingroup$ It does not become quite clear to me if the problem occurs with the mobile version, the full version, or both. $\endgroup$ – user9072 May 25 '14 at 22:20
  • 1
    $\begingroup$ I currently view MO and meta in the full versions, and other SE sites in (what look to me like) mobile versions. I will attempt viewing 22 in the mobile version, if I can navigate to that version and back. $\endgroup$ – The Masked Avenger May 25 '14 at 22:24
  • 1
    $\begingroup$ I was able to view the mobile version of 22 briefly, and at least one time successfully. I need to make a few more trials as I also had a browser shutdown in attempting the mobile version of 22, so I can't say yet that I have a solid workaround. It does bear promise though. $\endgroup$ – The Masked Avenger May 25 '14 at 22:34
  • $\begingroup$ Maybe it's a jquery bug. Try disabling javascript and see if the bug is still there? $\endgroup$ – Bjørn Kjos-Hanssen May 26 '14 at 7:56
  • $\begingroup$ Bug remained after disabling Javascript. $\endgroup$ – The Masked Avenger May 26 '14 at 17:24
  • 1
    $\begingroup$ Maybe try meta.stackexchange.com $\endgroup$ – Bjørn Kjos-Hanssen May 28 '14 at 6:21
3
$\begingroup$

Also, why should a browser abort occur in the first place?

That is the most important question – and the answer is, it shouldn't. No matter what a website does, the browser shouldn't allow it to cause a crash. That's why this is really a browser bug, which has a big chance of us not being able to do anything about it.

That said, if we knew a simple workaround for the problem, we would certainly employ it. However I am unable to even reproduce the issue on my old HTC Desire running Android 2.3.3, the closest I have to what you're running. I can look at the question just fine, both in mobile and in desktop mode.

Thus I'm afraid that using a different browser is really the only solution I can offer you here, sorry.

$\endgroup$
  • $\begingroup$ Since the question was recently edited (as I can see from navigating the revisions page), the thought occurs that the bug may be triggered by the revision. Is there any substantial difference between (the HTTP data that forms) the revised version and a year old copy that might explain what is going on? $\endgroup$ – The Masked Avenger May 28 '14 at 21:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .