8
$\begingroup$

I have some issue with the math font for quite some time now. And it only happens on this very site, and not on any other site.

Some of the letters, some of the time, don't render part of the top line of pixels. It's weird. If I increase or decrease the zoom factor in my browser, it goes away. But that's not a solution really.

Note the top of the $X$ and $Y$, as well the top of the $B$.

Screenshot

I have no idea what causes this, and this is the only site where it happens. It happens with Firefox, even in Private Browsing mode (so it's not an issue of cookies). With Chromium it works out just fine.

System details: Arch Linux 64bit, Firefox 26.0


EDIT:

The problem appears on Physics.SE as well, but not on Math.SE, as mentioned. This points out to a problem with the general layout (and in particular the font) of the sites (MO and Phy.SE use sans serif; MSE uses serif). I'm in contact with one of the MathJax developers, and further information will be posted when it is available.

$\endgroup$
  • $\begingroup$ I'm wondering if the upvotes indicate similar issues and if so on which systems. I'm unable to reproduce this on FF26 Ubuntu 13.10. @Asaf, do you have any plugins installed that might interfere with layout (e.g. ad blockers)? From a quick look, MO does not use any webfonts, so font issues should not be the core. I don't even think it's CSS, it might just be the random browser clipping we sometimes see. More information from other users would be extremely helpful. $\endgroup$ – Peter Krautzberger Jan 23 '14 at 11:26
  • $\begingroup$ Peter, restarting Firefox in safe mode (no plugins) gives the same result. The letters have choppy tops. Even safe mode + private browsing mode. $\endgroup$ – Asaf Karagila Jan 23 '14 at 11:28
  • $\begingroup$ Thanks, Asaf. Which Arch Linux version are you on? $\endgroup$ – Peter Krautzberger Jan 23 '14 at 11:44
  • $\begingroup$ What do you mean exactly? I use the vanilla kernel 3.12.7 (it's been going on through a couple of kernel updates, I just now decided to post a report, though). SLiM + OpenBox + various gtk-based libraries in the background. But I haven't installed or uninstalled anything significant that I can think of when that began. $\endgroup$ – Asaf Karagila Jan 23 '14 at 11:47
  • $\begingroup$ (Other than that, Arch is a rolling release, so there's no "Hardy Hermite" or "Feisty Freiburger" sort of versions to it...) $\endgroup$ – Asaf Karagila Jan 23 '14 at 11:48
  • $\begingroup$ @Peter: I think I found the issue. The CSS computes the MathJax font size as 18.4833px, whereas on MSE it computed as 16.2px. When modifying the MSE size to that value, the problem occurs there as well. $\endgroup$ – Asaf Karagila Jan 23 '14 at 12:12
  • $\begingroup$ The other difference is the computed line-height, 23px on MSE and 27px here. $\endgroup$ – Asaf Karagila Jan 23 '14 at 12:32
  • $\begingroup$ Hm. Chromium computes the same values, but the font is rendered just fine there. $\endgroup$ – Asaf Karagila Jan 23 '14 at 13:27
  • $\begingroup$ Thanks for the update on your Arch installation (I forgot it's rolling but good to know it's up to date). Thanks for the additional information. $\endgroup$ – Peter Krautzberger Jan 23 '14 at 14:23
  • $\begingroup$ No problem. Is there a way to force refreshing the font cache without deleting all the other cache from my drive? (Or maybe there's no font cache to begin with, I'm not versed in webfonts technology...) It seems to go across every site. If I change the font size to exactly 18.4833px this happens, any other value is fine. $\endgroup$ – Asaf Karagila Jan 23 '14 at 14:36
  • $\begingroup$ It should also be noted that on MSE the font size is 15px, whereas MO has 14px; but due to different fonts the computed MathJax font sizes are different (16.2 vs. 18.4833) $\endgroup$ – Asaf Karagila Jan 23 '14 at 14:39
  • $\begingroup$ The computed font sizes will vary not just from browser to browser but client to client since font rendering technology differs across operating systems. As for clearing the cache of just MathJax, I don't know. Maybe addons.mozilla.org/de/firefox/addon/cacheviewer2 works for you. $\endgroup$ – Peter Krautzberger Jan 23 '14 at 18:08
  • 2
    $\begingroup$ I've finally been able to reproduce this -- but only on Arch Linux. Reported at github.com/mathjax/MathJax/issues/724 $\endgroup$ – Peter Krautzberger Jan 23 '14 at 18:10
  • $\begingroup$ The fonts don't show up in the cache, it seems. I tried to refresh the whole MathJax related scripts, but it didn't work. It's interesting that you managed to reproduce this, but only on Arch. Did you install slim+obox like me, or stick to gnome/kde? $\endgroup$ – Asaf Karagila Jan 23 '14 at 18:15
  • $\begingroup$ I don't think clearing the cache will change this. I was using KDE. $\endgroup$ – Peter Krautzberger Jan 23 '14 at 18:17
3
$\begingroup$

As indicated in the comments, this seems to be a Firefox+Arch Linux specific problem. Interestingly enough, the Firefox binaries are compiled without applying any patches, so the problem must lie somewhere deeper in the rendering code.

Until such time where this issue becomes large enough to identify its source, here's a solution:

Right click over any $\LaTeX$ output, then "Math Settings", "Scale All Math ..." and set the factor to $99\%$. This will decrease the font size below the 18.4833px by enough to cause proper rendering, but not as much as to cause any visible change.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .